Friday, May 30, 2008

Motion Computing LE1600 won't charge

Motion Computing LE1600 Tablet PCs occasionally develop a problem where the unit won't charge because the AC adapter port on the right side of the tablet breaks on the inside where it attaches to the motherboard. People that call us about this problem usually think their AC adapter is bad. That has only been the case one time and it was obvious because the cord was damaged. To test whether you have this problem, you can try and charge the tablet via the Convertible Keyboard or FlexDock. If it charges fine using those devices, your problem is the AC adapter port.

Now for the bad news...

Motion used to fix those at their repair facility by soldering the AC port where it separated from the motherboard. Now, they replace the entire motherboard at a cost of around $700 and an average wait time of 2-6 weeks. YIKES!

And some good news...

Allegiance Technology can do the repair for $125 plus the cost of return shipping. This repair may void any warranty you have and is not authorized by Motion in any way. But it sure is faster and cheaper than the alternative. Call 877-772-5587 x3 if you have more questions.

5 comments:

Shannon said...

Thanks for the tip. My le1600 has been back to Motion twice for this issue. They covered it under warranty, but I am worried about it happening again now that I am out of warranty. All things considered, Motion makes a solid machine.

DGMECH said...

HI,

JUST CAME ACROSS THIS POST TODAY 7/18/08.

ANYWAY THE ON OFF SWITCH ON MY LE1600 STOPED WORKING TODAY. DOES YOUR COMPANY FIX THIS AS WELL? IF SO PLEASE LET ME KNOW. I LIVE IN THE PHILLY AREA

THANKS DOMINIC

John Hill said...

dgmech,

Unfortunately, there is no easy fix - they motherboard has to be replaced. Around $700 I think.

John

Kurisu said...

Don't know if anyone is still reading this but what if it won't charge from keyboard either? I swapped batteries with another le 1600 and it works but it isn't charging.

John Hill said...

@Kurisu

I haven't seen that problem before. I assume you are plugging the power cord into the keyboard, correct?

This is the place where we used to send all our tablets with this problem: http://www.power-jack-repair.com/

good luck!